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Quick Start
Overview
Welcome to WellSync. For the purpose of this document we are assuming that all users have a
valid login to an InterACT server. If you do not, then please procure one before proceeding.

To begin, populate your InterACT credentials:
•

Username : Your InterACT account username

•

Password : Your InterACT account password

•

Server : Your InterACT server
o

DO NOT put http:// or https:// in the Server box.

o

Only put www in the Server box if it is needed.

o

There should be no forward slashes (/) in your server address.

Review your URL box. This box can't be edited, but it shows you what WellSync thinks your
InterACT server address is. To specify the HTTP protocol, edit the following properties in the
%INSTALL_DIR%\WellSyncN\WellSyncN.exe.config file:
< add key="DevHTTPOverride" value="TRUE" />.
To specify the http port, change the following property in the same file to:
< add key="DevPortOverride" value="80" />.

InterACT Folder
Pressing the InterACT Folder Search button (2) in the main WellSync GUI launches the InterACT
Folder Search screen.
You can enter search criteria here or use wildcards to pull every folder that you have access to.
If nothing is returned, the program will try to search again ommitting the most general search
criteria.
Your search criteria will be remembered between sessions.
You can also access this screen by typing Ctrl+I or using the Run -> Select InterACT Folder Menu
Item.
Though you cannot search Sections or SubSections here, you will be able to desginate them in
the main User Interface after searching here.
Drill Down As Needed.

In the Main GUI you can now browse the Search Tree to find the Well, Section, or SubSection
you wish to communicate with. Click on your target so that it is Highlighted like Athena is in the
screenshot.
Empty Organizations.

Unless this checkbox is selected, the display of organizations that don't have any Wells
underneath will be suppressed.

InterACT Folder
The next input required from the user is the selection of the local directory to communicate to
or from. Pressing the Local Folder button (3) in the main WellSync GUI launches a standard
Folder Search screen.

Browse to your local folder ( or create new folders ) as you normally would in any application.

Configure Sync
The final stage is to configure the synchronization direction (upload files to InterACT, or
download files from InterACT), as well as the frequency to perform synchronization checks
between InterACT and the local machine running WellSync. The current release of WellSync
facilitates only unidirectional synchronization (i.e. upload or download). You may open and
configure more than one WellSync window, if desired.

Upload Synchronization is employed when the contents of a directory on the client machine
need to be uploaded (and synchronized) with a Field/Well/Section/SubSection on the InterACT
server selected.

Download Synchronization is used when the client needs a directory to be synchronized with
the contents of a particular Field/Well/Section/SubSection on the InterACT server. This means if
any new files/data arrives on the server it should be synchronized, and downloaded as
specified.
Synchronization Frequency is the delay between synchronization sessions. If you leave
WellSync running instead of closing it after you Synchronize a folder then it will wake up and
resynch the folder at this interval.
Start Synching!
Once you have set your Interact Folder, Local Folder, Synch Direction, and Synch Frequency you
are ready to go!

New Features
Summary
Note: A hidden file transfer limit of one has been added that restricts more than one DLIS file to
be uploaded to the RTDB database at a time. For server performance reasons, these files will be
restricted to a maximum of 1 file in flight regardless of what the active transfer limit is set to.

Name

Shell
Extension

Folder
Select

GUI

Sync Delay

Priority

Summary

Integrates with Windows File Explorer so users can right-click on a folder and
select it to synchronize with.

Provides local folder browsing and search windows in the InterACT system.

Integrates a table to help users watch every transfer at once.

Activates a pop-up window with a countdown that will delay the first sync.

Allows users to select different ways to order files being transferred. This feature
currently has only two ordering methods, but more will be added.

WellSync 8.0 will only permit a max of one DLIS files to be uploaded to the RTDB at once.

Shell Extension
This feature integrates WellSync with Windows Folder Explorer so that users can right-click on a
folder and select "Sync Folder" to launch WellSync.

The program will launch with the selected folder pre-populated as the local folder to
synchronize.

Folder Select
Several changes have been made to folder browsing both locally and in the InterACT system.
•

InterACT Folder Search
The logic used to search for wells on the InterAct server has been altered.

•

Local Folder Browser
A modern file browser has been added for the local side that allows users to create new
folders as needed.

InterACT Folder Search

•

Search Logic
There are some changes to the search logic.

•

•

In the results box, entries that have no wells underneath won't display. This will
reduce clutter. Users can reveal them by selecting the check box "Show Empty
Organizations" in the main graphical user interface (GUI).

•

If multiple criteria in the search return no results, WellSync will search again
omitting the most general criteria. For example, if a search on Org of "Demo*"
and a Well of "MyWell" produces no results, WellSync will try just searching for
"MyWell" to see if it exists in another organization.

i-District Job Number ( Job ID )
This feature only works for InterACT servers 7.x and later.
It allows the user to enter an i-District Job Number in WellSync. Then WellSync searches
for sections with that i-District Job Number and presents a list of sections that match
(similar to the old WellSync's filters for ORG, field, etc).

Local Folder Browser

•
•

If you click "Local Folder" then a standard folder browsing window will pop up for you to
select your synchronization folder.
You can also copy/paste the path directly into the Local Folder TextBox in the main GUI.

Graphical User Interface
WellSync has a new graphical user interface with several notable enhancements. The goal of
these changes was to make the interface more communicative and responsive to the user.

1) Server Drop-Down List.
Users can enter the InterACT server to connect to or select one from a new drop-down list
containing the major InterACT servers.
2) Show Empty Organizations.
The new InterACT folder search attempts to assist users by hiding undesirable results. An
organization or field that contains no wells is assumed to be undesirable. If this is not so, click
"Show Empty Organizations" to reveal them.
3) Moved the Synch Statistics.
To make a more effective use of space, unnecessary synch statistics were eliminated and the
useful ones were moved into a stripe. This allows the Synch Log to extend across the entire
width of the interface.
4) Synchronization Log View.

The lesser log window has been removed. The error messages are now displayed as pop-ups for
greater visibility.
•

The Synchronization Log was extended the full width of the screen.

•

Users can now copy and paste directly from the Synchronization Log.

•

The Synchronization Log no longer blanks every synch interval. New entries append until
the application is closed and re-opened.

5) Active Transfer Viewers.
The Active Transfer Viewer allows users to monitor the progress of each transfer. Users can also
use it to abort and resume individual transfers within a synchronization batch.
The Active Transfer Viewer displays the validation status of the files, but it is subject to
significant time delay. Network administrators require that we keep traffic to a minimum so
Wellsync only looks for validation data every 30 seconds. Also, some files keep their validation
information in the footer instead of in the header so the entire file will have to upload before
the server can even attempt to validate it. And users can expect up to a minute's delay after file
completion for validation to begin.
6) Divider.
The draggable divider sets the height of the Active Transfer Viewer and the Synchronization
Log. If desired, the divider can be raised to hide the text log screen entirely and users can rely
on the Active Transfer viewer to monitor transfer status.
7) Save Server.
This button stores servers that are not in the server Drop Down.

Sync Delay
Currently in WellSync when you click 'Stopped - Click to Start' the client immediately performs a
synch request and then checks in every synch interval to see if there is more to do. Some users
with poor bandwidth have requested the ability to delay that first synchronization so that they
don't have to manually kick it off late at night.

Go to Advanced -> Misc -> Set Synchronization Properties dialog to let the user specify an
initial delay and a checkbox to activate/deactivate the initial delay feature.
When the user starts synchronization a check is run to see if the delay control is turned on. If
so, a modal dialog pops up with a countdown running for the first sync. The modal will also
contain a brief explanation of the Delay feature and instructions on how to turn it off.

Priority
WellSync was designed to allow programmers to easily create ordering methodologies and
swap between them on the fly. It will be used by product owners to define different ways of
prioritizing file transfers to meet the needs of end users.
Select default transfer priority by going to Advanced -> Misc -> Set File Priority

Name

Description

Alphabetical

Files will transfer in alphabetical order. If a file is unable to run because a user is
already at the RTDB/DLIS quota, it will be skipped until there is an opening to run
a RTDB/DLIS file.

If users are not loading DLIS files to the RTDB, Wireline runs exactly like
Alphabetical. If users are loading DLIS files to the RTDB, then it creates a
separate line for DLIS files that is organized by creation date (most recent first)
and gives that line higher priority.

Wireline

Each transfer attempts to get a RTDB/DLIS file, but will settle for an alphabetical
one if the high-priority line is empty—or if a user is at the limit of one
simultaneous RTDB/DLIS file in flight.
On the very first sync interval, and only on that interval, all DLIS files except the
three newest will be demoted and loaded into the InterACT system as normal
rather than RTDB files. Demoted files are sent to the alphabetical line. DLIS files
added to the source directory later on will be added to the RTDB/DLIS line in
order of creation date without demotion.

When uploading DLIS files to the RTDB Database with an Activity of Wireline, files will use
Wireline Prioritization regardless of the settings.

User Guide
File Menu
These are the options in the File Menu Drop Down:

•
•
•

Log Synchronization Runs
Writes Synchronization Logs to WellSyncLog_[timestamp].txt
Log Performance Metrics
Writes transfer details to AppDirectN_Metrics_[timestamp]_[fileNum].txt
Exit WellSync (Ctrl+E)
Will exit the WellSync application.

Logs are all stored in the Logs folder in the application directory. This is typically under Program
Files -> Schlumberger -> WellSyncN although a shortcut to the directory is also available from
Start -> All Programs -> Schlumberger -> WellSyncN.
These log files will take up a lot of space and should be periodically deleted if you do not
disable logging.

Run Menu
These are the options in the Run Menu Drop Down:

•
•
•

Select InterACT Folder (Ctrl+I)
Launches The InterACT Folder Search window as if you had clicked the InterAct Folder
Button in the Main User Interface.
Select Local Folder (Ctrl+L)
Launches The Local Folder Search window as if you had clicked the Local Folder Button
in the Main User Interface.
Start Synchronizing (Ctrl+S)
Begins the synchronization process. If synchronization is already running then pressing
Ctrl+S' will stop the current synchronization. This option will be greyed out if you have
not entered in a username/password or selected folders or are otherwise missing some
step that needs to be completed for a successful synchronization.

View Menu
These are the options in the View Menu Drop Down:

•

•
•

Logs
Displays the corresponding log files. Each file is uniquely named with an appended
timestamp. Each instance of the WellSync application will create its own version of
these files. If you want to review old versions of these files, you need to browse to the
Logs folder in the application directory and open them manually.
InterACT Web Page (Ctrl+W)
Feature Currently non-functional.
Server Messages (Ctrl+M)
Displays a window that shows the last/current message sent from the InterACT server.

This may contain text or text with associated XML from the server and can be useful
during problem diagnosis.

Advanced Menu
These are the options in the Advanced drop-down menu:

•

Filters
Filtering controls which files are synchronized and which are ignored.

•

Archival
Activate TransACT archiving.

•

Misc.
Assorted synchronization settings.

•

Proxy Login Settings
Authenticate with a proxy server.

Filters

•

Set File Filter This menu selection opens a dialog window that allows a user to specify a
filter for the types of files considered for synchronization. Different settings can be
applied depending on whether the upload or download mode is set. The filter can apply
to which file types will be considered or not considered for synchronization. The user
can also disable file filtering if desired.
The filter defined in this example will only upload .dlis and .bmp files and only download
.txt files.
Filtering is case insensitive and only applies to file extensions.

•

Set Download Activity
Set Download Activity can be used to specify that only files associated with a particular
InterACT activity will be synchronized and downloaded. If the Activity name is left blank,
is set to an Activity that does not exist for the selected Field/Well/Section, or is not
checked to enable the filtering, then the Activity filter is disregarded.

Archival

•

Archive Uploaded Files
If the organization level within the InterACT system has “Upload files to TransACT”
enabled, a user can enable this setting (checkmark indicates enabled) to also archive the
files as they are uploaded to the InterACT and TransACT systems.

Miscellaneous

•

Set Active Transfer Limit (ATL)
This setting allows a user to limit the number of active transfers allowed at any one
time. This can be used to improve file transfer throughput for users on smaller
bandwidth connections. The more simultaneous files allowed, the lower the bandwidth
available to each file. If the ATL is reached, no new transfers will be initiated until it
drops below the number specified here. The ATL can be set to a maximum value of 30
active transfers.

•

Set Upload Activity, Category, and Load to Real-Time Viewers This configuration
allows the user to configure files to be loaded to the InterACT real-time database (RTDB)
and the InterACT catalog. A user can select the Activity and Category so each file type is
configured automatically. Files (DLIS, LAS, WITSML, XML(WITSML)) can only be uploaded
to the RTDB if they are uploaded into a Section. The user can specify to be prompted to
select a Category and Activity for each file that is not log data.

•

Set Synchronization Properties
WellSync can delay its first synchronization run rather than starting the moment
immediately after users click Start Syncing. For example, users can start a delayed synch
run when they leave work. When transferring files late at night, there is less
competition for bandwidth.

•

Set File Priority
WellSync was designed to allow programmers to easily create ordering methodologies
and swap between them on the fly. This will be used by product owners to define
different ways of prioritizing file transfers to meet the needs of end users. For more
details, go to New Features.

•

Proxy Login Settings
If WellSync is being run in an environment that requires authentication to a Forward
Proxy Server in order to access the Internet, the security credentials for the Proxy Server
may be entered into this dialog for authentication. Note that this does not support
setting the Domain, only User Name and Password.

Help Menu
These are the options in the Help Menu Drop Down:

•
•
•

User Guide (Ctrl+U)
Links user to this most excellent User's Guide.
Version History
Links user to the developer's notes in Readme.txt.
About WellSync
Presents a Splash screen that details version and copyright information.

Validation Rules
File validation is available for log files (DLIS, LAS, PDS) to ensure files published by Schlumberger
users are not published into the wrong place. If validation is enabled, the Company name, Field
name, and Well name (if file is in a Well) parameters are compared to the file header, prior to
publishing into InterACT. Validation can be enabled or disabled from the Edit Organization
Details page of InterACT. The InterACT File Details page shows the validation status of a log file.
A Poor Match is when the company name has a spelling error of one character only, though
spaces are ignored for the comparison (i.e. Shlum berger). A Poor Match is only allowed for
company name, not for field or well name.
The publisher is informed of validation failure through the InterACT Web user interface, and
from the WellSync Active Transfer Viewing Table. Because querying the server for validation
status creates a lot of chatter, WellSync only updates validation status every 30 seconds.

Passed Validation Failed Validation Bypassed Validation
Is Published Into InterACT

X

Is Available For Download By All

X

Can Only Be Downloaded By The Owner

X

X
X

X

Can Be Loaded To The RTDB

X

X

Can Be Archived

X

Shows As "Pass" in WellSync Viewer

X

X

Can Be Downloaded By Programatic Clients

X

X

Is Only Visible To Admins And Owner

X

May Only Move Or Copy at the Section Level

X

Versioning
The WellSync application runs on a client machine and provides file synchronization capabilities
between an InterACT server and a local directory. It can perform automatic transfers of
multiple files simultaneously over HTTP(s). WellSync runs on the following operating systems:
•

Windows XP ( 32/64 bit )

•

Windows Vista ( 32/64 bit )

•

Windows 7 ( 64 bit )
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05/05/2011

1.3
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Known Issues
The following are items that the development team of WellSync is aware of at the time of this
release. For a more up-to-date list, visit Bug Tracking on the WellSync Wiki.
•

The menu item View -> InterACT Web Page only works if users are already logged in to
the appropriate InterACT server in the default Web browser.

•

Clicking on Fail in the Validation column doesn't show failure details.

•

On Windows 7, telling the operating system to increase font sizes distorts the graphical
user interface (GUI).

Future Enhancements
•

GUI enhancements for a more FTP-like GUI

•

Support for recursive downloading of subfolders and their contents

•

A section and subsection creation feature in the WellSync user interface

•

Proxy server capabilities

•

Logging improvements

